PHP7.0.2から7.1.5にしたらphpMyAdminでエラー

ソフトウェアネットワーク

ダウンロードしたPHP7.1.5をローカルで動作確認をしました。
別に不都合もなく動いているようでした。

ところが、phpMyAdminを起動してみると、下の方にエラーメッセージが出まくり。どうも「Crypt」がいけないみたいです。

phpサイトで
「PHP 7.0.x から PHP 7.1.x への移行」

のページに、「PHP 7.1.x で推奨されなくなる機能」というのがあり、そこで 「mcrypt拡張モジュールは非推奨になり、かわりに OpenSSL を使いましょう。」と案内がありました。

で、php.ini ファイルの

;extension=php_openssl.dll のところを
extension=php_openssl.dll

にコメントを外したところ、エラーも出なくなりました。